2010.07.21
 

V5R2へのダウングレード

Question

V5R4 へアップグレードしたのですが、問題が発生して V5R2 にダウングレードしなければならなくなりました。これには OS のフレッシュ・インストールが必要でした。SAVLIB からライブラリーをバックアップしましたが、現在 V5R2 システムでライブラリーのリストアに苦労しています。V5R2で動作するよう変換する方法はありませんか。そうでないと、V5R4 を再インストールしなければなりません。

Answer

デフォルトの Target Release (TGTRLS) パラメーター値 (SAVLIB ... TGTRLS(*CURRENT)) を使用して V5R4 下でライブラリーが保存されたため、以前のリリースではリストアはできません (しかし V6R1 以降のリリースでは可能です)。下位互換性機能はありません。ライブラリーを別の V5R4 システムでリストアし、TGTRLS(V5R2M0) を使用して再度保存する必要があります。ライブラリーに保存されているプログラム・オブジェクトについても注意する必要があります。それらも V5R2M0 リリース・レベルと互換性がなければならないためです。

ページトップ

ボタン